Troubles with campfire

Hello, I was wondering if anyone could help me. I have gone over the settings in an attempt to make the game as easy for me as possible, and I have added only 7 mods. I was able to get the game started but when I try to cook some meat on the campfire, there is no key to light fire. I hit the E, I can load wood and meat into the campfire but according to a video I was watching earlier, I am supposed to find a button on the bottom that says to Light Campfire. There is nothing there and I am running out of food. I have plenty of woof and meat, but as I said I cannot find any way to light the campfire under “E”. Anyone who can help me? I am playing solo, and NONE for a choice. Thank you.

I’ve encountered similar problems in the past. Try crafting a new campfire or picking it up the old one and placing it down again. In single player you can also try admin spawning one in.

I have tried and tried what you mentioned and it does work. Any other suggestions? Anyone? I build a campfire, I load it with wood and meat and there is no way to light the fire. Therefore, I am stuck eating berries. Is there a mod that will help? Thank you all for any help or information. What do you mean by admin spawning in one? Also, I am playing solo. Should I be on an official server?

‘cheat giveitemnum 39 1 0 0’ or ‘giveitemnum 39 1 0 0’ using the console command screen (default ‘Tab’) in single player.

Check engrams? Make sure campfire is learned?

If all else fails, consider how far along you are. If you just started (trying to survive by cooking meat over campfire is very early game), maybe just delete your save and restart?

I have had that problem when I inadvertently placed it too close to water.
It didn’t look like it was in water, but it was.

It was very frustrating for me.