Page Load Error each time I visit the forums

#1

I hope this is the right place for this. I’ll start with the good news as feedback. I really like the new digs as I am getting used to them. This has a very nice look. I need to do the tutorial, etc. but I’ll get to it. Anyway, I have become fond of using Firefox on both Windows 10 Pro and iOS. I haven’t tried the site at all on iOS yet. What I have encountered each time I visit is this error:

Corrupted Content Error

The site at Looking to rejoin the EQ2 Crew has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

Please contact the website owners to inform them of this problem.

I can clear this by using the feature in Firefox to delete saved info for just this page and then hitting refresh. At that point, I get the login screen since my cookies were deleted and so I login and then I am brought directly to the page I had bookmarked.

EDIT:

The solution to this issue in case it helps anyone else, is to remove the Privacy Badger extension from Firefox. Disabling it for this site is not enough. Why? Who knows? I know I don’t care.

I don’t know why I even had it honestly. I only use LastPass, Adblock Plus and Clip to OneNote. I added this one recently on a recommendation I read somewhere. Simple is better yet again. It’s gone.

Raid naked! That’s what I say! If somebody really wants to turn on my camera or whatever and see that, well, that’s their problem. I don’t care!

0 Likes