Installation Issues

Hi all,

So I was going to reinstall GW2 so I set it to download over night. When I came back to it this morning, it was less than half done and set at zero speed. I tried it again and watched it and it downloaded for about 10 mins at good speed and then dropped to zero again and didn’t move. I tried some fixes and nothing worked. I have not had any issues with my internet or speed and have been downloading a game on steam with no issues.

Any thoughts or ideas would be helpful. Just curious if anyone has run into this before.


Never had that issue, but one of the very common issues is that if you’re running Microsoft Security Essentials, it can keep a lock on certain files. If you do, you can manually exclude your games or GW2 directory from ever being ‘actively’ scanned.

The real-time protection of that service can cause issues like you’re describing when the game can’t access a file.

Other than that… Not a clue :slight_smile:

I’ve run into this with GW1 (I’ve recently been playing it). Unfortunately it’s difficult to say what’s going on here because there are so many variables involved. As @Splutty mentioned, it could be something on your machine, or it could be your computer’s connection to the servers they use to host the files, or anything in between.

I think the best advice is to just keep it open. It should eventually start downloading again. If you wanted to try and actually find out why, you’ll quickly fall down the diagnosis rabbit hole, and you may not even arrive at an answer.

Thanks all. Yeah, I have tried everything I can think of. Not using Essentials and disabled all AV. Just started too so its odd. Never had an issue with GW 2 before on this machine (or any other download as well.

I am officially stumped.

You can try the 64-bit client however it sounds like your issue is more network related.

Wiki Page:

Also, see this form post, specifically the -log option at the end. If you pursue this you should be able to get closer to the issue at hand.


Could your ISP be throttling your download speed?

FWIW, I just installed the game on a new machine a few days ago, and it went through fine.

Nope. Its something with GW2 and I have not seen it before and stumped. We pay for unlimited.

I dont have great Internet being in the mountains but better than what we did.

This week I downloaded Destiny 2 (I think around 80 gigs), and also ESO around 60 or so.

Destiny downloaded in just a few hours with no hiccup or issue. Same with ESO.

So I tried GW2 again. Even tried a different drive. Ran as admin, etc…tried every fix I could find. Nada. Nothing worked.

It would start downloading and get up to around my max speed and be fine. I think it had like 500k files and it would be great. Then around 350k files it would start dropping to 0/kbs. It was sit there for a few and then go back up. The odd part is the file countdown would stop too. NO matter what I did it would stay at the number it stopped at. Also “playable” would move to the far left and not move.

It is very odd. I have had no issue with any game this week or download. And I have played GW2 since launch and installed and uninstalled several time and never seen anything like this.

Silly thing maybe, but is your disk full?

1 Like

No, got 700 megs free on one and 200 on the other. Tried both as well.

700 M I don’t think that’s enough, do you mean 700Gs?

Yeah gigs.

SO I figured it out. Every night when I would set it to install, the PC was “sleeping” after a while. I guess when I woke it up and went back to look at the download bar/counter, it was simply messing up the bar so it was looking complete but continuing to download. The bar really wasn’t “full” or complete. Odd, I know but I will take it.

I tried one more time today and set my pc not to go into sleep mode and had no issues. Just a really really big download.

Good to hear! And I never thought that might be an issue. None of my machines ever go to sleep.

Mine does not now! :slight_smile: